Problem with saving campaigns / approving invoices
Incident Report for audienzz
Resolved
This incident has been resolved.
Posted May 03, 2023 - 18:28 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 03, 2023 - 08:06 UTC
Investigating
We are currently investigating this issue.
Posted May 03, 2023 - 07:14 UTC